Services : Actualité Emploi Blog Forum Flux
Formation Trafic : Référencement Liens sponsorisés Affiliation Ecommerce Nom de domaine E-réputation Marketing Mobile Black Hat
Formation Technique : Performance Web Html Css Sql Curl Asp Dotnet Php Ajax Wordpress Twitter Google Analytics

Forum Oseox
Oseox

Redirection avec exception

Forum Référencement et Trafic
Nous sommes le Sam 25 Nov 2017 08:46

Heures au format UTC [ Heure d’été ]




Poster un nouveau sujet Répondre au sujet
Auteur Message
MessagePosté: Lun 19 Avr 2010 09:13 
Avatar de l’utilisateur
Bonjour tout le monde,

Voilà je suis pas très doué en dev et je me heurte à un petit problème avec mon URL rewriting.

Le topo est simple :
- Je redirige mes URLs de la manière suivante : http://www.monsite.com/index.php/mapage.html vers http://www.monsite.com/mapage.html. J'enlève donc la partie index.php pour toutes les pages et sous-dossiers de mon site.
- Là où ça coince c'est que c'est un site en magento et donc ça enlève le index.php présent dans les liens pour la console d'admin.

Ce que je recherche à faire donc c'est :
- Continuer à rediriger mes URLs sans ce index.php mais le laisser pour http://www.monsite.com/index.php/admin

La solution est peut être évidente mais je suis vraiment pas un crack là-dedans...

Merci d'avance pour votre aide. :)


Haut
 Profil Envoyer un e-mail  
 
MessagePosté: Lun 19 Avr 2010 09:42 
Professionnel
Professionnel
Avatar de l’utilisateur
Hello, un simple :

Code:
RewriteRule ^index\.php\/admin - [L]


En haut de ton fichier htaccess/apache devrait suffire à régler ton souci (sous réserve de modification de magento que je connais assez peu), il suffit que ton autre règle soit placée après.


Haut
 Profil Envoyer un e-mail  
 
MessagePosté: Lun 19 Avr 2010 10:54 
Avatar de l’utilisateur
Salut Stephane, merci pour ta réponse malheureusement ça ne marche pas.
Quand j'ajoute cette ligne la redirection ne se fait plus du tout. J'ai essayé de placer ces lignes dans divers endroits dans le fichier, d'enlever les \ mais rien à faire. Maintenant y'a tellement de bordel dans le htaccess de base que je sais pas si ça bloque quelque part d'autre...

Merci quand même en tout cas.


Haut
 Profil Envoyer un e-mail  
 
MessagePosté: Lun 19 Avr 2010 11:28 
Professionnel
Professionnel
Avatar de l’utilisateur
La ligne que je t'ai envoyé sert à ignorer les règles de réécriture si l'url commence par index.php/admin : cela dit je n'ai pas vraiment regardé plus avant magento.

Si magento possède une fonctionnalité te permettant de de retirer index.php des URLs, je dirai a priori que ton problème vient d'un paramètre magento que tu as modifié et non du htaccess : voici un htaccess qui fonctionne bien avec la fonction que tu cherches :

Code:
<IfModule mod_rewrite.c>
    Options +FollowSymLinks
    RewriteEngine on
    RewriteBase /
    RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]
    RewriteCond %{REQUEST_URI} !^/(media|skin|js)/
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteCond %{REQUEST_FILENAME} !-l
    RewriteRule .* index.php [L]
</IfModule>


Haut
 Profil Envoyer un e-mail  
 
MessagePosté: Lun 19 Avr 2010 12:09 
Avatar de l’utilisateur
J'ai la même chose sauf pour

Code:
RewriteBase /


A la place j'ai :

Code:
#RewriteBase /magento/


J'ai essayé de mettre la même chose mais ça ne change rien.
Et après la dernière ligne j'ai des redirections particulières de pages qui fonctionnent.

Quand je place mes deux lignes au-dessus de :

Code:
RewriteRule .* index.php [L]


La redirection ne marche pas et je perd même les CSS.
Par contre après cette ligne ça ne fait rien. :/


Haut
 Profil Envoyer un e-mail  
 
MessagePosté: Lun 19 Avr 2010 13:59 
Professionnel
Professionnel
Avatar de l’utilisateur
Si tes css/js et images sont dans media/skin/js

remplace

Citation:
RewriteCond %{REQUEST_URI} !^/(media|skin|js)/


par

Citation:
RewriteCond %{REQUEST_URI} !^(media|skin|js)


et ne te préoccupe plus de la ligne que j'ai écrit au dessus, sinon pour chacun des dossiers qui contient tes images, ajoute les dans l'expression.
Essaie ensuite d'accéder à /admin ou /index.php/admin

(je suis pas un pro de magento, j'y vais à tatons)


Haut
 Profil Envoyer un e-mail  
 
MessagePosté: Lun 19 Avr 2010 14:29 
Avatar de l’utilisateur
Rien à faire, tant pis je vais devoir laisser ce index.php tout moche partout dans mes URLs.

Merci beaucoup pour ton aide en tout cas Stephane.


Haut
 Profil Envoyer un e-mail  
 
MessagePosté: Lun 19 Avr 2010 14:40 
Administrateur
Avatar de l’utilisateur
J'avais essayé avec dotclear... sans succès également :s


Haut
 Profil Envoyer un e-mail  
 
MessagePosté: Lun 19 Avr 2010 16:18 
Professionnel
Professionnel
Avatar de l’utilisateur
S'il s'agit d'un serveur de dev, tu peux me donner temporairement un accès que je regarde, je trouve ça étrange (sinon une copie des fichiers/base avec les logins/pass sql).


Haut
 Profil Envoyer un e-mail  
 
Afficher les messages postés depuis:  Trier par  
Poster un nouveau sujet Répondre au sujet  [ 9 messages ] 

Heures au format UTC [ Heure d’été ]


Qui est en ligne

Utilisateurs parcourant ce forum: Aucun utilisateur enregistré et 1 invité


Vous ne pouvez pas poster de nouveaux sujets
Vous ne pouvez pas répondre aux sujets
Vous ne pouvez pas éditer vos messages
Vous ne pouvez pas supprimer vos messages
Vous ne pouvez pas joindre des fichiers

Rechercher:
Aller à:  
cron
Abonnez-vous au flux RSS

Blog

Forum

Offres d'emploi

Copyright : Moteur, traduction et optimisation
Merci de votre visite sur le forum Oseox